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1 Overview

TeX/LATEX is a typesetting system that allows for easy creation of mathe-
matical symbols and equations. TeX has become popular because it is both
in the public domain and documents created with TeX are archival and thus
don’t change or become unloadable over time. It’s now fairly easy to install
a TeX/LATEX system on your microcomputer and it even comes with various
front-ends you can use so that you can customize your own TeX experience.

This document will go over installing a standard TeX/LATEX system on a
Windows or Macintosh microcomputer. A base TeX/LATEX installation nor-
mally includes two parts: a TeX/LATEX base system and a front-end system
from which to easily use the TeX/LATEX base. Additional information on
how to add the isuthesis package to the installation will also be included.

2 Windows Installation

ProTeXt puts a complete public domain tex system on your Windows system
for use with creating papers, writing document or making a thesis with TeX
and LATEX.

You can get a free copy of the ProTeXt CD-Rom from the Solution Center,
195 Durham Center, during normal business hours. You can also download
ProTeXt from http://www.tug.org but it is kind of large so it might take
a considerable amount of time to download.
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2.1 Getting Started with ProTeXt

Take the ProTeXt CD-Rom and put it into your CD-Rom drive. Choose to
install the English version of ProTeXt and click Next. After a little waiting,
an initial PDF file should pop up. If it doesn’t show up automatically, use
Acrobat and open the protext-install-en.pdf file at the top level of the CD-
Rom within the Install Folder.

ProTeXt uses a PDF file to guide you through a basic TeX installation.
You actually click on links in the PDF file to install TeX on your machine. A
standard Windows installation involves two main parts: a main TeX system
(MikTeX) and a TeX interface or front-end (TeXnicCenter). We will be
installing a few little extras as well. Let’s start by installing MikTeX.

2.2 Installing MikTeX

Browse down into the PDF file until you see the line:
Click here to install MikTeX

and click that spot in the file. This will startup the MikTeX installation. You
basically take most of the defaults and install a Complete TeX installation.
So the proper responses to the prompts are: Next, Next, Complete then
Next*5. At this point, write down the Local Tree information then press
Next, Next and Next. You will then have a long wait while MikTeX creates
a complete TeX installation. Go and get a sandwich. It takes about thirty
minutes or more.

When the long wait is over, press Next followed by Finish. Your base
TeX system is now installed. If you look under the Start Menu under Pro-
grams you should now find a TeX option. But wait, unless you want to use
LATEX from the command line, you will probably want to install a front-end
and a couple more things as well.

2.3 Installing a LATEX front end

2.3.1 Installing TeXnicCenter

Go back to your installation PDF file and browse down the file until you find:
Click here to install TeXnicCenter

and click that spot in the file.
This time simply take all the installation defaults, accept the terms and

conditions, and click the box to make a desktop link for using TeXnicCen-
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ter. Click the Finish button when it pops up and TeXnicCenter has been
installed. TeXnicCenter allows you to use all the major LATEX functions
by pressing buttons in a pleasant Windows environment. It also includes a
rather simple text editor. Once you are finished with the installation, if you
look under the Start Menu under Programs you should now find a TeXnic-
Center option to use.

2.3.2 Installing WinShell

TeXnicCenter is a standard LATEX front-end that a lot of people use but
another popular choice is WinShell. If you would like to use that front-end
rather than or in addition to TeXnicCenter, go to:

http://www.winshell.de

and click on the Download WinShell link. You will have the option of
downloading from various sites— simply choose one of the self-installing
WinShell31.exe downloads and click it to start the downloading. Once the
download completes, double-click on the installer and once that starts click
on the Install button then the Run button.

Basically take all the defaults by clicking Next, Accept the terms and
conditions then click Next, Next*2, click to create a desktop icon then click
Next and click Finish to exit the installer.

You should now have a complete version of WinShell available to you
from under the Start Menu under Programs.

2.3.3 Other Windows Front-Ends/Editors

There are many other LATEX front-ends or editors that you might use with a
TeX base. For other front-ends you might try, take a look at the free editors
section at the bottom of the following web page:

http://www.emacswiki.org/cgi-bin/emacs-en/CategoryTex

2.4 Installing Ghostscript/Ghostview

Ghostscript/Ghostview allow a standard TeX installation to show graphics
when using the standard LATEX compiler. If you are going to use the standard
LATEX compiler then go down a little further into the PDF file and install
both of these packages. Just take the defaults and it should end up being
very easy to install.
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2.5 Finishing Up

Viola! All the major installations for using TeX and LATEX on a Windows
system are now complete. You might add the isuthesis style files or a spelling
checker for LATEX a little later on but other than that your TeX system is
ready to go.

2.6 Adding isuthesis or your own style files

To add the isuthesis style files to your TeX installation, go to the following
URL:

http://css.ait.iastate.edu/Tex/

and click on the isuthesis link followed by the isuthesis package link. Save
all the files in the isuthesis folder as well as the fullpage.sty and the mut-
licol.sty files to a folder on your desktop named isuthesis. You can do this
by right-clicking on each style file and downloading it to a selected folder on
your desktop.

Next go to the following location on the C drive:
C:\texmf\tex\latex\

This should be the location where the local texmf tree as created by ProTeXt.
If it’s not, use the location given by ProTeXt. Move the isuthesis folder
from your desktop into the latex folder.

Now you just need to rebuild your tex system since you’ve added some
additional style files. Go under Start → Programs → MikTeX → Mik-
TeX Options and under the General tab click on the Refresh button.
This will probably take a little while to complete. Click OK once completed
to finish.

You now have installed the isuthesis package. You can download the
thesis template files from:

http://css.ait.iastate.edu/Tex/

by clicking on the isuthesis link and then clicking on the standard isuthesis
template link. Save all the files listed there to a single folder then compile
the thesis.tex file with LATEX.

2.7 Adding a Spelling Checker

A normal spelling checker will have trouble working with LATEX due to all the
LATEX commands in a LATEX file. So you normally have to install a special
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spelling checker that knows about TeX and LATEX commands. TeXnicCenter
comes with a spelling checker already installed but if you are using WinShell
then you need to install your own spelling checker. Two free spelling checkers
for the Windows version of LATEX are 4Spell and GNU Aspell.

2.7.1 Installing 4Spell

You can download 4Spell on the Web at:
http://4tex.ntg.nl/4tex5/download/4Spell/

You will need to download and unzip both 4spell.zip and us.zip from this
web site. Unzip and extract the two files and place the 4spell Folder some-
where on your system where you can find it and place the us.dic file from
the US folder inside of the 4spell Folder in a folder there named 4spell.

To initialize 4spell, run the program 4spell.exe in the 4spell Folder.
Click the Select Language button and choose the English (American)[US]
option. 4spell should now be configured for correct use.

To use 4spell, click the Select File button and choose the file that you
want to spell check. The file will open inside of 4spell. Then click on the
Check Spelling button.

To add 4spell as an option to Winshell, start Winshell then pull down un-
der Options→User Programs and choose Tool1. Click the Browse but-
ton and find the 4spell.exe program on your system then click Open. Next
change the cmd - Line option to %pc. Finally uncheck all the boxes in the
lower righthand corner named: LaTeX first, PDFlatex first, and DVIPS first;
then click the OK button. After this setup, you can enter CTRL/Shift/F1
at any time within WinShell to bring up 4spell.

2.7.2 GNU Aspell

GNU Aspell works very nicely with WinShell and actually allows you to use
the Spell Check button within WinShell. You can download GNU ASpell on
the Web from:

http://aspell.net/win32/

Download both the Full Installer and the English dictionary. Once you
have it downloaded, double-click the Full Installer and take all the defaults
for installation. Next install the English dictionary taking all the defaults
for this one as well.
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You should now have Aspell properly installed and be able to click on the
Spell Check button within WinShell which looks like a checkmark to start
Aspell.

3 Macintosh Installation

It’s fairly easy to download and install a full TeX/LATEX system on your
Mactinosh. The TeX base system is simple to install using the i-Installer
application and then you can choose either iTeXMac or TeXShop as your
front-end. There is also a MacTeX package that comes from the TeX Users
Group (TUG) which is extra easy to install as it comes as a standard Mac-
intosh package and it includes a standard front-end with it.

3.1 Installing the MacTeX Package

The MacTeX package provides a very easy way to install a TeX base on your
Macintosh including a standard Macintosh front-end (TeXShop). Simply go
to:

http://www.tug.org/mactex/

and click on the image to download your installation. The package installs
like any other normal Macintosh package so simply double-click on the Mac-
TeX.dmg icon then double-click the MacTex-2007.mpkg icon to begin
installation. Take the default options for a complete TeX installation and
a full TeX installation should be created for you in about thirty minutes.
Quick, easy and mostly painless except for the download time.

3.2 Installing with i-Installer

i-Installer provides a fairly simple way to install complicated package systems
onto your Macintosh with relative ease. You can download i-Installer from
the Web at the following URL:

http://ii2.sourceforge.net/tex-index.html

Click on the II2.dmg link that is about halfway down the page. Complete
and install a basic installation of the i-Installer package taking all the de-
faults. The i-Installer package should end up in the Utilities Folder within
your Applications folder on your Macintosh.
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Next startup i-Installer and pull down under i-Package → Known
Packages i-Directory. Choose the Gerben’s i-Directory TUG i-Directory
on the left and select the TeX package on the right. Next click on Open
i-Package and then click on the Install and Configure button. Choose a
Basic installation and take the other defaults. At this point take a break for
a sandwich and when you come back your base TeX/LATEX system should be
installed.

3.3 Installing a Macintosh Front-End

There are two main competing front-ends to choose from on the Macintosh:
iTeXMac and TeXShop. I would recommended either one or both. TeXShop
seems to work better on Intel-based Macintosh systems than iTeXMac but
either front-end is good.

3.3.1 Installing iTeXMac

iTeXMac can be obtained and downloaded from:
http://itexmac.sourceforge.net/

Simply download and extract the application then take the iTeXMac appli-
cation and place it into your Applications folder. You might then make an
alias for the application that you can place in your Dock.

Once you startup iTeXMac, simply pull down under File → New to
create a new LATEX document. Then compile your document by going under
TeX to Typeset. iTeXMac primarily uses pdflatex and thus by default
creates a PDF file as a result.

3.3.2 Installing TexShop

TexShop can be obtained and downloaded from:
http://www.uoregon.edu/~koch/texshop/

Simply download and extract the application then take the TeXShop appli-
cation and place it into your Applications folder. You might then make an
alias for the application that you can place in your Dock.

Once you startup TeXShop, simply pull down under File → New to
create a new LATEX document. Click the Typeset button to compile your
document with LATEX. TeXShop primarily uses pdflatex and thus by default
creates a PDF file as a result.
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3.3.3 Other Macintosh Front-Ends/Editors

There are many other LATEX front-ends or editors that you might use with a
TeX base. For other front-ends you might try, take a look at the the following
two web pages:

http://www.esm.psu.edu/mac-tex/frontends.shtml

http://www.emacswiki.org/cgi-bin/emacs-en/CategoryTex

3.4 Adding isuthesis or your own style files

To add the isuthesis style files to your TeX installation, go to the following
URL:

http://css.ait.iastate.edu/Tex/

and click on the isuthesis link followed by the isuthesis package link. Save
all the files in the isuthesis folder as well as the fullpage.sty and the mut-
licol.sty files to a folder on your desktop named isuthesis. You can do this
by ctrl-clicking on each style file and downloading it to a selected folder on
your desktop.

Next open up your Library folder, then open up your texmf folder and
finally open up your mylocal folder. If you don’t have a mylocal folder, create
a mylocal folder inside your texmf folder. Click and drag your isuthesis
folder to be inside your mylocal folder.

iTexMac and TeXShop may have additional locations where you can put
your local style files. Check the iTeXMac and TeXShop help files for more
information on where your local style files could also be located.

You now have installed the isuthesis package. You can download the
thesis template files from:

http://css.ait.iastate.edu/Tex/

by clicking on the isuthesis link followed by the standard isuthesis template
link. Save all the files listed there to a single folder then compile the the-
sis.tex file with LATEX.

3.5 More Macintosh Information

Both iTeXMac and TeXShop come with a spelling checker built-in so there is
no need for an external spelling checker. A really good resource for additional
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Mactinosh Tex/LATEX information is the Penn State Macintosh Web site
which is located at:

http://www.esm.psu.edu/mac-tex/

Textures is a commercial Macintosh-only TeX application. It is available
from:

http://www.bluesky.com/

It includes a external interactive editor interface for LATEX so that as you are
typing in LATEX commands you can actually immediately see what the result
of your commands will look like. Textures is one of the most respected and
impressive TeX products and is also one of the most expensive.

4 For Additional Information

Additional information on Tex and LATEX use at ISU is available on the Web
at:

http://css.ait.iastate.edu/Tex/

Try the Classes link for information on how to use TeXnicCenter, iTeXMac
or TeXShop from the “Introduction to LATEX” class handout notes. There
are also two online full length LATEX classes to view from the Classes page
which if you are in a hurry is a great way to get started with LATEX. Also try
the FAQ link for a set of stock questions and answers regarding LATEX.
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